1. WAOYOU首页
  2. 编程
  3. 易语言

易语言如何判断是否相邻的几个数?

在爬虫或者其他运算的时候,会使用到连续判断相邻与否的效果,通过是否相邻数来进行判断程序的执行顺序与否,那么易语言如何判断是否相邻的几个数呢?这里给出判断4个数字是否为相邻数的运算逻辑,给大家参考。

效果如下:

1、当给出1,2,3,4的时候,返回真;

2、当给出1,2,3,5的时候,只保留5并返回假;

数字是其中判断的依据。

易语言如何判断是否相邻的几个数?



.版本 2
.支持库 spec

.子程序 是否相邻, 逻辑型
.参数 id, 整数型
.局部变量 num, 整数型

调试输出 (id)
num = 取数组成员数 (m_array)
.如果真 (num < 4)
    加入成员 (m_array, id)
    num = 取数组成员数 (m_array)
    .如果真 (num = 1)
        返回 (假)
    .如果真结束
    .如果真 (num = 2)
        .如果真 (m_array [2] - m_array [1] ≠ 1)
            删除成员 (m_array, 1, )
            返回 (假)
        .如果真结束

    .如果真结束
    .如果真 (num = 3)
        .如果真 (m_array [3] - m_array [2] ≠ 1)
            删除成员 (m_array, 1, 2)
            返回 (假)
        .如果真结束

    .如果真结束
    .如果真 (num = 4)
        .判断开始 (m_array [4] - m_array [3] ≠ 1)
            删除成员 (m_array, 1, 3)
            返回 (假)
        .默认

            删除成员 (m_array, 1, 4)
            调试输出 (m_array, 4)
            返回 (真)
        .判断结束

    .如果真结束

.如果真结束
调试输出 (m_array, “!!”)
返回 (假)

当然,这个逻辑也可以用到其他的编程语言里,这里做个记录。
易语言如何判断是否相邻的几个数?

原创文章,作者:神经蛙,如若转载,请注明出处:https://www.waoyou.com/576.html

声明:本文观点不代表WAOYOU立场,转载请联系文章原作者。如文章内容或图片涉及版权,敬请联系本站进行删除。WAOYOU,陪你一起看世界!

联系我们

在线咨询:点击这里给我发消息

电话:17638350532

工作时间:周一至周五,9:30-18:30,节假日休息

QR code